Website is down
Resolved
Apr 4, 2026 at 1:21pm UTC
The DDoS attack has been successfully mitigated.
All services are now fully operational and traffic has returned to normal levels.
Our systems remain protected and stable.
If you experience any issues, please refresh the page or clear your browser cache.
Affected services
Updated
Apr 4, 2026 at 1:10pm UTC
We are currently experiencing a DDoS attack, which is causing service disruption and downtime.
Our mitigation systems are active and we are working on stabilizing the infrastructure.
Some users may still experience issues accessing the website.
We will provide further updates as soon as possible.
Affected services
Created
Apr 4, 2026 at 1:00pm UTC
The website is currently unavailable due to a DDoS attack.
This type of attack floods our servers with a large amount of fake traffic, which prevents normal access.
Our protection systems are being activated and we are actively working to restore service.
Affected services