Back to overview
Downtime
Miraculous.is is down
Apr 25, 2026 at 12:37pm UTC
Affected services
Miraculous.is
Resolved
Apr 25, 2026 at 12:40pm UTC
Server reset was completed.
Affected services
Created
Apr 25, 2026 at 12:37pm UTC
We are performing a hard reset of our server. Downtime is acceptable. We are also creating a backup and updating the software to improve the website’s performance and speed.
Affected services